Dnes se dovíte, jak v Excelu vyrobíte jednoduchou aplikaci, pro zkontrolování validity, roku narození a pohlaví z rodného čísla.

Zde najdete hotový vzor. Stáhnout

Okénko, do kterého se bude zadávat čísla z rodného čísla (C8) ve formátu xxxxxx/xxxx, nebo xxxxxx/xxx (v tom případě nezjistíte validitu), si rozkouskujeme příkazem =ČÁST(C8;1;2) /E8/ ; =ČÁST(C8;3;2) /E9/ ; =ČÁST(C8;5;2) /E10/ ; =ČÁST(C8;8;2) /E11/ ; =ČÁST(C8;10;2) /E12/ do pěti okének. V podstatě jsme udělali to, že jsme vyňali dvojice čísel: Rok narození, měsíc narození, den narození a koncovku, která odlišuje dvě osoby se stejnými předchozími údaji.

Následně si vyneseme hodnoty dvojčísel do políček C16 až C20 příkazem =HODNOTA(E8) až po E12.

Potom už můžeme udělat políčko, v kterém se nám ukáže datum narození vzorcem =KDYŽ(C17>12;DATUM(C16;C17-50;C18);DATUM(C16;C17;C18)) a dáme mu formát čísla Datum. Vzorec nám říká, že když měsíc narození je více jak 12, tak datum narození je rok, měsíc "minus" 50 a den. Když není měsíc vyšší jak 12, tak klasicky rok, měsíc a den.

Dále můžeme udělat bez problému políčko pohlaví vzorcem =KDYŽ(C17>12;"žena";"muž"). V podstatě jde o to že na občanském průkazu se rozlišuje pohlaví tak, že ženám se do měsíce přičte 50. Od nedávné doby se mužům někdy přičítá 20, v tomto návodu s tím ale nepočítáme pokud byste chtěli, tak všechny 12 ve vzorcích přepíšeme na 32.

Validitu zkontrolujeme sečtením všech dvojčísel =SUMA(C16:C20) /E16/ a vydělíme 11. Jestliže zbytek po celočíselném dělení bude 0, tak je validita správná, na to použijeme vzorec =MOD(E16;11).

Nakonec si můžeme udělat políčko pro věk, tak že z buňky kde máme datum narození např /G17/ vzorcem   =(DNES()-G17), odečteme od dnešního data jeho datum narození a formát buňky nastavíme -> vlastní typ: rr (jako rok).

Tímto aplikaci máme hotovou.

tmp tmp

TOPlist
hodnocenní bazarů od zákazníků, recenze autobazarů, hodnocení autobazarů, zkušenosti s autobazary